Muscle Growth - Discord Bot is back up – Incident details
Email Us
MuscleGrowth.net
Get updates
Email
Discord
RSS
Atom
Email Us
MuscleGrowth.net
Get updates
All systems operational
Discord Bot is back up
Resolved
Major outage
Started 29 days ago
July 24, 2026
Lasted 32 minutes
July 24, 2026
11:45
12:17
UTC
Affected
Discord Bot
Major outage from 11:45 AM to 12:17 PM
Updates
Resolved
July 24, 2026 at 12:17
UTC
Resolved
July 24, 2026 at 12:17
UTC
Discord Bot is back up.
Investigating
July 24, 2026 at 11:45
UTC
Investigating
July 24, 2026 at 11:45
UTC
Discord Bot is down at the moment. We have started to investigate.
UTC
UTC
UTC
UTC
UTC